22 дек. 2009 г.

Обновление xen-tools в Vyatta VC5 после обновления Citrix Xenserver 5.5 Update 1

После выхода обновления update1 для Citrix XenServer 5.5 все виртуальные машины в один голос сообщили, что их xen-tools is outdated. Соответственно была предпринята попытка обновить гостевые утилиты. Операционные системы использующиеся у меня: Microsoft Windows Server 2003, Debian Lenny, Vyatta VC5. С Windows платформой никаких вопросов при обновлении не возникло, с Debian тоже, кроме того, что пришлось руками в GRUB вернуть назад ядро 2.6.29-xs5.5.0.14 вместо 2.6.29-xs5.5.0.15, которое утилиты установили самостоятельно. Заменить ядро назад пришлось в связи с его ошибками при загрузке. Пришла очередь Vyatta... Хоть этот дистрибутив базируется на Debian, скрипту установки не удалось распознать версию ОС и он отказался работать. Поэтому пришлось победить эту бяку таким способом:

sudo mount /dev/xvdd /mnt
sudo dpkg -i /mnt/Linux/xe-guest-utilities_5.5.0-464_i386.deb
reboot


После перезагрузки, XenCenter больше не жаловался на устаревшие xen-tools.
Отправить комментарий